Card transactions being declined - EEA customers

Incident Report for Spendesk

Resolved

We can confirm that as of April 2nd 00:29 CET, the incident resulting in some card transaction being declined has been resolved.

There have been no further declines since. We will continue to monitor and provide another update if required.
Posted Apr 02, 2025 - 10:32 CEST

Identified

Our partner has identified the incident and have confirmed that the declines started on March 12, 2025.
Their engineering teams have been engaged and are working to resolve it as soon as possible.
Posted Mar 28, 2025 - 18:13 CET

Investigating

We have identified an issue resulting in some card transaction being declined.

This incident only affects card transactions by EEA customers.

We are in contact with our provider, and we will provide an update as soon as it becomes available.

Please accept our apologies for the inconvenience, and thank you for your patience.
Posted Mar 28, 2025 - 12:57 CET
This incident affected: Cards (Virtual Cards, Physical Cards, Subscription Cards).