Errors and high latency on Spendesk
Incident Report for Spendesk
Resolved
This incident has been resolved.
Posted Sep 17, 2024 - 12:28 CEST
Investigating
We are experiencing some latencies. As a result, the loading time is higher.

Our technical team is looking into this, and we will provide an update with sharable information, when possible.
Posted Sep 17, 2024 - 12:19 CEST
This incident affected: Bookkeeping (Bookkeep > Prepare) and Invoices (Invoices).